Ubuntu11.04でrails

今までrubyは使ってたけどrailsは使ったことなかったので、少し勉強を始めました。 ubuntuのaptでgemを入れると、最新のものが使えなかったりしていろいろハマるので、別にいれた方がよさそうです。 また、railsのバージョンも2.xと3.xでいろいろ違うみたいなので、今回は両方の環境を入れてrvmで切り替えられるようにします。 参考にしたのは Ruby on Rails on Ubuntu 11.04 | 嘘つき女 です。 関連するパッケージなどをインストール。 $ sudo apt-get install gcc build-essential $ sudo apt-get install bison byacc gperf zlib1g-dev libssl-dev $ sudo apt-get install libreadline5 libreadline5-dev libncurses5 libncurses5-dev sqlite3 libsqlite3-dev curl rvm(Ruby Version Manager)を入れる。 URLが変わっているかもしれないので、…